メインコンテンツにスキップ
バージョン: v2.2.0

インストール

サポートされているプラットフォーム

  • Windows 10/11 AMD64/ARM64
  • MacOS 10.13+ AMD64
  • MacOS 11.0+ ARM64
  • Linux AMD64/ARM64

依存関係

Wailsをインストールする前に、下記のものを導入しておく必要があります。

  • Go 1.18+
  • NPM (Node 15+)

Go

Download Go from the Go Downloads Page.

公式のGoインストール手順に従って、Goをインストールしてください。 その際、PATH環境変数に~/go/binディレクトリへのパスが含まれていることも確認してください。 それらが終わったら、ターミナルを再起動し、以下の確認をしてください:

  • Goが正しくインストールされているかを確認する: go version
  • "~/go/bin"のディレクトリパスがPATH環境変数に含まれているか確認する: echo $PATH | grep go/bin

NPM

NodeダウンロードページからNPMをダウンロードしてください。 最新版を利用することをお勧めします。なぜなら、私たちは最新版に対してテストを実施しているためです。

npm --versionを実行して、インストールが完了しているかを確認してください。

プラットフォーム固有の依存関係

開発作業を行うプラットフォームによって、必要な依存関係が存在します:

Wails requires that the WebView2 runtime is installed. Some Windows installations will already have this installed. You can check using the wails doctor command.

任意の依存関係

  • UPXを導入することで、構築したアプリを圧縮できます。

Wailsのインストール

go install github.com/wailsapp/wails/v2/cmd/[email protected]を実行して、Wails CLIをインストールしてください。

Note: If you get an error similar to this:

....\Go\pkg\mod\github.com\wailsapp\wails\[email protected]\pkg\templates\templates.go:28:12: pattern all:ides/*: no matching files found

please check you have Go 1.18+ installed:

go version

システムチェック

wails doctorを実行すると、必要な依存関係が正しくインストールされているかを確認することができます。 正しくインストールされていない場合は、その内容をあなたにお知らせして、どうすれば解決できるかを教えてくれます。

wailsコマンドが見つからないのですが?

wailsコマンドが見つからないとシステムに怒られた場合は、Goが、公式のGoインストール手順に従って導入されているかを確認してください。 コマンドが見つからないほとんどの理由は、あなたのホームディレクトリ配下にあるgo/binディレクトリのパスが、PATH環境変数に含まれていないからです。 また、インストールによって行われた環境変更を反映させるために、もともと開いていたコマンドプロンプト(ターミナル)がある場合はそれらをいったん閉じて、再度開きなおしてください。